CVE-2025-62519: thorsten phpMyFAQ · SQL Injection
Affects thorsten phpMyFAQSource CVE Database V5
Not known to be exploited · CVSS 7.2 High : upgrade to 4.0.14 soon.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.0.14
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 17 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade thorsten/phpMyFAQ to 4.0.14.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubthorsten/phpMyFAQpkg:github/thorsten/phpMyFAQOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
- Immediately upgrade all phpMyFAQ installations to version 4.0.14 or later to apply the official patch addressing this vulnerability.
- Review and restrict 'Configuration Edit' permissions to the minimum necessary number of trusted administrators to reduce the risk of insider threats or compromised accounts.
- Implement strong authentication mechanisms (e.g., multi-factor authentication) for all privileged users to mitigate unauthorized access.
- Conduct regular audits of user permissions and monitor configuration changes within phpMyFAQ for suspicious activity.
- Employ web application firewalls (WAFs) with custom rules to detect and block SQL injection attempts targeting phpMyFAQ endpoints.
- Ensure database user accounts used by phpMyFAQ have the least privileges necessary, limiting the impact of any SQL injection exploitation.
- Maintain regular backups of phpMyFAQ databases and configurations to enable rapid recovery in case of compromise.
- Monitor security advisories and threat intelligence feeds for any emerging exploits related to this vulnerability to respond promptly.
Description
phpMyFAQ is an open source FAQ web application. Prior to version 4.0.14, an authenticated SQL injection vulnerability in the main configuration update functionality of phpMyFAQ allows a privileged user with 'Configuration Edit' permissions to execute arbitrary SQL commands. Successful exploitation can lead to a full compromise of the database, including reading, modifying, or deleting all data, as well as potential remote code execution depending on the database configuration. This issue has been patched in version 4.0.14.