Skip to main content
VulnerabilityPublished Updated

CVE-2025-62599: eProsima Fast-DDS · Integer Overflow or Wraparound

Affects eProsima Fast-DDSSource CVE Database V5

0

Not known to be exploited · CVSS 8.6 High · fixed in 3.4.2 : patch eProsima Fast-DDS soon.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.4.2, 3.3.1, 3.2.4 +2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
eProsimaFast-DDSAffected
  • <2.6.11
  • >=2.7.0 <2.14.6
  • >=3.0.0 <3.2.4
  • >=3.3.0 <3.3.1
  • >=3.4.0 <3.4.2
Fixed in
  • 3.4.2
  • 3.3.1
  • 3.2.4
  • 2.14.6
  • 2.6.11

AI-suggested

This vulnerability is fixed in eProsima Fast DDS versions 2.6.11, 2.14.6, 3.2.4, 3.3.1, and 3.4.1. Users should upgrade to one of these versions or later to remediate the issue. Patch status is confirmed by the vendor advisory embedded in the description. No additional mitigation steps are indicated.

Description

eprosima Fast DDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group). Prior to 2.6.11, 2.14.6, 3.2.4, 3.3.1, and 3.4.1, when the security mode is enabled, modifying the DATA Submessage within an SPDP packet sent by a publisher causes an Out-Of-Memory (OOM) condition, resulting in remote termination of Fast-DDS. If the fields of PID_IDENTITY_TOKEN or PID_PERMISSION_TOKEN in the DATA Submessage — specifically by tampering with the length field in readPropertySeq — are modified, an integer overflow occurs, leading to an OOM during the resize operation. This vulnerability is fixed in 2.6.11, 2.14.6, 3.2.4, 3.3.1, and 3.4.1.

References

Community reviews

Loading reviews…