CVE-2025-62600: eProsima Fast-DDS · Integer Overflow or Wraparound
Affects eProsima Fast-DDSSource CVE Database V5
Not known to be exploited · CVSS 8.6 High · fixed in 3.4.2 : patch eProsima Fast-DDS soon.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.4.2, 3.3.1, 3.2.4 +2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 3 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| eProsimaFast-DDS | Affected
| Fixed in
|
| eProsimaFast-DDS | Affected
| Fixed in
|
| eProsimaFast-DDS | Affected
| Fixed in
|
| eProsimaFast-DDS | Affected
| Fixed in
|
| eProsimaFast-DDS | Affected
| Fixed in
|
GitHubeprosima/Fast-DDSpkg:github/eprosima/Fast-DDSOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in eProsima Fast-DDS versions 2.6.11, 2.14.6, 3.2.4, 3.3.1, and 3.4.1. Users should upgrade to one of these versions or later to remediate this vulnerability. No other mitigation or workaround is indicated in the available data.
Description
eprosima Fast DDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group). Prior to 2.6.11, 2.14.6, 3.2.4, 3.3.1, and 3.4.1, when the security mode is enabled, modifying the DATA Submessage within an SPDP packet sent by a publisher causes an Out-Of-Memory (OOM) condition, resulting in remote termination of Fast-DDS. If the fields of PID_IDENTITY_TOKEN or PID_PERMISSION_TOKEN in the DATA Submessage — specifically by tampering with the length field in readBinaryPropertySeq— are modified, an integer overflow occurs, leading to an OOM during the resize operation. This vulnerability is fixed in 2.6.11, 2.14.6, 3.2.4, 3.3.1, and 3.4.1.