CVE-2025-62601: eProsima Fast-DDS · Heap-based Buffer Overflow
Affects eProsima Fast-DDSSource CVE Database V5
Not known to be exploited · CVSS 1.7 Low · fixed in 3.4.1 : update eProsima Fast-DDS when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.4.1, 3.3.1, 2.6.11
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:UExploitation evidence
Disclosed: evidence found.
CVE published 3 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade eProsima Fast-DDS to 3.4.1, 3.3.1 or 2.6.11.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| eProsimaFast-DDS | Affected
| Fixed in
|
GitHubeprosima/Fast-DDSpkg:github/eprosima/Fast-DDSOther threats | Affected
| Fixed in– |
GitHubFast-DDSpkg:github/Fast-DDSOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately upgrade eProsima Fast-DDS to versions 3.4.1, 3.3.1, or 2.6.11 or later to remediate this vulnerability. In addition, network segmentation should be enforced to restrict access to DDS communication ports only to trusted and authenticated devices, minimizing exposure to malicious SPDP packets. Implementing strict input validation and anomaly detection on DDS traffic can help identify and block malformed or tampered DATA Submessages. Monitoring Fast-DDS process health and setting up automated restart mechanisms can reduce downtime in case of unexpected termination. Organizations should also review and harden their DDS security configurations, ensuring that only authorized publishers can send SPDP packets. Finally, conducting regular vulnerability assessments and penetration testing on DDS deployments will help detect similar issues proactively.
Description
Fast DDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group ). Prior to versions 3.4.1, 3.3.1, and 2.6.11, when the security mode is enabled, modifying the DATA Submessage within an SPDP packet sent by a publisher causes a heap buffer overflow, resulting in remote termination of Fast-DDS. If the fields of `PID_IDENTITY_TOKEN` or `PID_PERMISSIONS_TOKEN` in the DATA Submessage — specifically by tampering with the `str_size` value read by `readString` (called from `readBinaryProperty`) — are modified, a 32-bit integer overflow can occur, causing `std::vector::resize` to use an attacker-controlled size and quickly trigger heap buffer overflow and remote process term ination. Versions 3.4.1, 3.3.1, and 2.6.11 patch the issue.
References
- security-tracker.debian.org/tracker/CVE-2025-62601 (opens in a new tab)
- github.com/eProsima/Fast-DDS/commit/354218514d32beac963ff5c306f1cf159ee37c5f (opens in a new tab)
- github.com/eProsima/Fast-DDS/commit/ced3b6f92d928af1eae77d5fe889878128ad421a (opens in a new tab)
- github.com/eProsima/Fast-DDS/commit/a726e6a5daba660418d1f7c05b6f203c17747d2b (opens in a new tab)