Skip to main content
VulnerabilityPublished

CVE-2025-62714: karmada-io dashboard · Missing Authorization

Affects karmada-io dashboardSource CVE Database V5

0

Not known to be exploited · CVSS 8.7 High : upgrade to 0.2.0 soon.

Data as of 26 Oct 2026, 11:42 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.2.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade karmada-io/dashboard to 0.2.0.

Affected software

ProductAffectedFixed in
GitHubkarmada-io/dashboardpkg:github/karmada-io/dashboardOther threatsAffected
  • <0.2.0
Fixed in
  • 0.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade to version 0.2.0 or later once available, as versions prior to 0.2.0 are affected. If you cannot patch yet, restrict network access to the Karmada Dashboard API endpoints to trusted users only to mitigate unauthorized access.

Description

Karmada Dashboard versions prior to 0.2.0 contain an authentication bypass vulnerability in their backend API endpoints. These endpoints do not enforce authentication, allowing unauthenticated users with network access to retrieve sensitive cluster information such as Secrets and Services. The web UI requires JWT authentication, but the API itself is exposed without checks. This vulnerability is identified as CWE-862 and has a high severity score of 8.7.

References

Community reviews

Loading reviews…