CVE-2025-62857: QNAP Systems QuMagie · Cross-site Scripting
Affects QNAP Systems QuMagieSource CVE Database V5
Not known to be exploited · CVSS 2.2 Low : upgrade to 3.0.0 or 2.8.1 when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.0.0, 2.8.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:H/SI:L/SA:N/E:UExploitation evidence
Disclosed: evidence found.
CVE published 2 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade QNAP Systems QuMagie to 3.0.0 or 2.8.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| QNAP Systems Inc. QuMagie | Affected
| Fixed in
|
AI-suggested
- Upgrade all QuMagie installations to version 2.8.1 or later immediately to apply the official patch addressing CVE-2025-62857.
- Implement strict input validation and output encoding on all user-supplied data within the application to prevent injection of malicious scripts.
- Deploy Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in browsers accessing QuMagie.
- Educate users about the risks of interacting with untrusted links or content that could trigger XSS attacks, reducing the likelihood of successful exploitation.
- Monitor application logs and network traffic for unusual activity indicative of attempted XSS exploitation.
- Conduct regular security assessments and penetration testing focused on web application vulnerabilities, including XSS, to identify and remediate issues proactively.
- Where possible, isolate QuMagie instances within segmented network zones to limit lateral movement if exploitation occurs.
Description
A cross-site scripting (XSS) vulnerability has been reported to affect QuMagie. The remote attackers can then exploit the vulnerability to bypass security mechanisms or read application data. We have already fixed the vulnerability in the following version: QuMagie 2.8.1 and later