CVE-2025-64174: OpenMage magento-lts · Cross-site Scripting
Affects OpenMage magento-ltsSource CVE Database V5
Not known to be exploited · CVSS 4.6 Medium : upgrade to 20.16.0 when convenient.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 20.16.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade openmage/magento-lts to 20.16.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubopenmage/magento-ltspkg:github/openmage/magento-ltsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
The primary mitigation is to upgrade all affected OpenMage magento-lts instances to version 20.16.0 or later, where the vulnerability is fixed. Until upgrade is possible, organizations should restrict administrative database access to trusted personnel only and implement strict access controls and monitoring on admin accounts. Input validation and output encoding should be enforced on all translation strings and notification feed data to prevent injection of malicious scripts. Regularly audit and sanitize translation files and notification data sources to detect and remove any injected payloads. Employ web application firewalls (WAFs) with rules targeting XSS patterns in admin interfaces. Additionally, enable multi-factor authentication (MFA) for admin accounts to reduce the risk of credential compromise. Monitor logs for unusual admin activity or unexpected script execution within the admin panel. Conduct security awareness training for administrators to recognize and report suspicious notifications or behaviors.
Description
Magento-lts is a long-term support alternative to Magento Community Edition (CE). Versions 20.15.0 and below are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an admin with direct database access or the admin notification feed source to inject malicious scripts into vulnerable fields. Unescaped translation strings and URLs are printed into contexts inside app/code/core/Mage/Adminhtml/Block/Notification/Grid/Renderer/Actions.php. A malicious translation or polluted data can inject script. This issue is fixed in version 20.16.0.