CVE-2025-64406: Apache OpenOffice · Out-of-bounds Write
Affects Apache OpenOfficeSource CVE Database V5
Not known to be exploited · CVSS 4.3 Medium · fixed in 4.1.16 : update Apache OpenOffice when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.1.16
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 12 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software Foundation Apache OpenOffice | Affected
| Fixed in– |
AI-suggested
- Upgrade all Apache OpenOffice installations to version 4.1.16 or later immediately to apply the official patch.
- Implement email filtering and attachment scanning to detect and block suspicious or malformed documents that could exploit this vulnerability.
- Educate users about the risks of opening documents from untrusted or unknown sources to reduce the likelihood of successful social engineering.
- Employ application whitelisting and sandboxing where feasible to limit the impact of crashes or malicious documents.
- Monitor endpoint logs for crashes or abnormal behavior in Apache OpenOffice that could indicate attempted exploitation.
- Consider transitioning to alternative office suites with more active security maintenance if Apache OpenOffice usage is widespread and patching is delayed.
- Maintain regular backups of critical documents and configurations to ensure rapid recovery from potential disruption.
Description
An out-of-bounds Write vulnerability in Apache OpenOffice could allow an attacker to craft a document that would crash the program, or otherwise corrupt other memory areas. This issue affects Apache OpenOffice: through 4.1.15. Users are recommended to upgrade to version 4.1.16, which fixes the issue.