CVE-2025-64775: Apache Struts · Incomplete Cleanup
Affects Apache StrutsSource CVE Database V5
Not known to be exploited · CVSS 7.5 High · fixed in 6.8.0 : patch Apache Struts soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 1.5% chance of exploitation in 30 days – higher than 74% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.8.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 1 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.struts/struts2-corepkg:maven/org.apache.struts/struts2-coreOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
- Immediately upgrade Apache Struts to versions 6.8.0 or 7.1.1 where the vulnerability is patched.
- Implement strict limits on multipart request sizes at the web server or application level to reduce the potential for disk exhaustion.
- Monitor disk usage continuously on servers running Apache Struts to detect abnormal increases in temporary file storage.
- Configure automated cleanup scripts or processes to remove orphaned temporary files if patching cannot be done immediately.
- Employ web application firewalls (WAFs) with rules to detect and block suspicious multipart requests that could trigger the vulnerability.
- Conduct regular security audits and vulnerability scans focusing on Apache Struts components.
- Educate development and operations teams about the risks associated with multipart request handling and proper resource management.
- Isolate critical applications on dedicated infrastructure to limit the blast radius of potential denial of service attacks.
Description
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.