Skip to main content
VulnerabilityPublished

CVE-2025-65020: lukevella rallly · Improper Authorization

Affects lukevella ralllySource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 4.5.4 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.5.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade lukevella/rallly to 4.5.4.

Affected software

ProductAffectedFixed in
GitHublukevella/ralllypkg:github/lukevella/ralllyOther threatsAffected
  • <4.5.4
Fixed in
  • 4.5.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations using Rallly should immediately upgrade to version 4.5.4 or later, where the vulnerability is patched. Until upgrade, implement strict access controls and monitor API usage for anomalous poll duplication requests. Employ logging and alerting on poll duplication endpoints to detect unauthorized attempts. Conduct an audit of existing polls to identify any unauthorized clones created prior to patching. Consider restricting poll duplication functionality to trusted roles or users, if possible, via configuration or custom access controls. Additionally, enforce strong authentication mechanisms to prevent unauthorized access to the platform. Educate users about the risks of sharing poll links or credentials. Finally, integrate vulnerability scanning and patch management processes to ensure timely updates of open-source tools like Rallly.

Description

Rallly is an open-source scheduling and collaboration tool. Prior to version 4.5.4, an Insecure Direct Object Reference (IDOR) vulnerability in the poll duplication endpoint (/api/trpc/polls.duplicate) allows any authenticated user to duplicate polls they do not own by modifying the pollId parameter. This effectively bypasses access control and lets unauthorized users clone private or administrative polls. This issue has been patched in version 4.5.4.

References

Community reviews

Loading reviews…