Skip to main content
CVE-2025-65035VulnerabilityPublished

CVE-2025-65035: pluginsGLPI databaseinventory · Deserialization of Untrusted Data

Affects pluginsGLPI databaseinventorySource CVE Database V5

0

Not known to be exploited · CVSS 6.4 Medium : upgrade to 1.1.2 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.1.2
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade pluginsglpi/databaseinventory to 1.1.2.

Affected software

ProductAffectedFixed in
GitHubpluginsglpi/databaseinventorypkg:github/pluginsglpi/databaseinventoryOther threatsAffected
  • <1.1.2
Fixed in
  • 1.1.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade the pluginsGLPI Database Inventory Plugin to version 1.1.2 or later to remediate this vulnerability. Beyond patching, organizations must audit and tighten database access controls to prevent unauthorized write access, as exploitation depends on this prerequisite. Implement strict input validation and sanitization for any user-supplied data stored in the database to reduce risks of unsafe deserialization. Employ web application firewalls (WAFs) with rules targeting deserialization attacks to detect and block suspicious payloads. Conduct thorough security assessments and penetration tests focusing on GLPI deployments to identify any other vulnerabilities or misconfigurations. Monitor logs for unusual activity related to the 'computergroup' parameter or PHP object instantiation patterns. Finally, educate administrators and users about the risks of interacting with untrusted data and the importance of applying security updates promptly.

Description

pluginsGLPI's Database Inventory Plugin "manages" the Teclib' inventory agents in order to perform an inventory of the databases present on the workstation. Prior to version 1.1.2, in certain conditions (database write access must first be obtained through another vulnerability or misconfiguration), user-controlled data is stored insecurely in the database via computergroup, and is later unserialized on every page load, allowing arbitrary PHP object instantiation. Version 1.1.2 fixes the issue.

References

Community reviews

Loading reviews…