Skip to main content
CVE-2025-65082VulnerabilityPublished

CVE-2025-65082: Apache HTTP Server · Improper Neutralization of Escape, Meta, or Control Sequences

Affects Apache HTTP ServerSource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium · fixed in 2.4.66 : update Apache HTTP Server when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.66
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
Apache Software Foundation Apache HTTP ServerAffected
  • =2.4.0
Fixed in–

AI-suggested

To mitigate CVE-2025-65082, European organizations should immediately upgrade Apache HTTP Server to version 2.4.66 or later, where the vulnerability is fixed. In environments where immediate upgrade is not feasible, administrators should audit Apache configuration files for any custom environment variable settings that could override server-calculated variables, especially those passed to CGI programs. Implement strict validation and sanitization of environment variables within CGI scripts to reduce risk. Disable or restrict CGI execution where not necessary to minimize the attack surface. Employ web application firewalls (WAFs) with rules designed to detect and block suspicious environment variable manipulations or injection attempts. Regularly monitor server logs for unusual CGI behavior or environment variable anomalies. Conduct vulnerability scanning and penetration testing focused on CGI interfaces to identify potential exploitation. Finally, maintain an inventory of Apache HTTP Server versions in use across the organization to ensure timely patch management.

Description

Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache HTTP Server through environment variables set via the Apache configuration unexpectedly superseding variables calculated by the server for CGI programs. This issue affects Apache HTTP Server from 2.4.0 through 2.4.65. Users are recommended to upgrade to version 2.4.66 which fixes the issue.

References

Community reviews

Loading reviews…