Skip to main content
CVE-2025-66036VulnerabilityPublished Updated

CVE-2025-66036: Anjaliavv51 Retro · Cross-site Scripting

Affects Anjaliavv51 RetroSource CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium : upgrade to 2.4.7 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade anjaliavv51/Retro to 2.4.7.

Affected software

ProductAffectedFixed in
GitHubanjaliavv51/Retropkg:github/anjaliavv51/RetroOther threatsAffected
  • <2.4.7
Fixed in
  • 2.4.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary mitigation is to upgrade the Retro platform to version 2.4.7 or later, where the vulnerability is patched. Organizations should implement strict input validation and output encoding on all user-supplied data to prevent script injection. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts. Conduct regular security audits and penetration testing focusing on input handling components. Educate users and staff about phishing and social engineering tactics that could be used to exploit this vulnerability. Monitor web application logs for suspicious input patterns or unusual user activity. If upgrading immediately is not feasible, consider deploying web application firewalls (WAFs) with rules to detect and block XSS payloads targeting Retro. Finally, maintain an incident response plan to quickly address any exploitation attempts.

Description

Retro is an online platform providing items of vintage collections. Prior to version 2.4.7, Retro is vulnerable to a cross-site scripting (XSS) in the input handling component. This issue has been patched in version 2.4.7.

References

Community reviews

Loading reviews…