Skip to main content
CVE-2025-66169VulnerabilityPublished Updated

CVE-2025-66169: Apache Camel Neo4j · Cypher Injection

Affects Apache Camel Neo4jSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium · fixed in 4.17.0 : update Apache Camel Neo4j when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.17.0, 4.14.3, 4.10.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade Apache to 4.17.0, 4.14.3 or 4.10.8.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Camel Neo4jAffected
  • >=4.10.0 <4.10.8
  • >=4.14.0 <4.14.3
  • >=4.15.0 <4.17.0
Fixed in
  • 4.17.0
  • 4.14.3
  • 4.10.8
Mavenorg.apache.camel/camel-neo4jpkg:maven/org.apache.camel/camel-neo4jOther threatsAffected
  • =4.10.0
  • =4.14.0
  • =4.15.0
Fixed in–
MavenApache Software Foundation/org.apache.camel:camel-neo4jpkg:maven/Apache Software Foundation/org.apache.camel:camel-neo4jOther threatsAffected
  • >=4.10.0 <4.10.8
  • >=4.14.0 <4.14.3
  • >=4.15.0 <4.17.0
Fixed in
  • 4.10.8
  • 4.14.3
  • 4.17.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Upgrade Apache Camel to the patched versions: 4.10.8 for 4.10.x LTS, 4.14.3 for 4.14.x LTS, or 4.17.0 for 4.15.x and later branches. 2. Implement strict input validation and sanitization for all data inputs that are incorporated into Cypher queries to prevent injection of malicious payloads. 3. Employ parameterized queries or prepared statements where possible to separate code from data in Cypher query construction. 4. Monitor Neo4j query logs and Apache Camel integration logs for unusual or unexpected query patterns indicative of injection attempts. 5. Restrict network access to Neo4j and Apache Camel endpoints to trusted internal networks and enforce strong access controls. 6. Conduct security code reviews and penetration testing focused on injection vulnerabilities in the integration layer. 7. Educate developers and DevOps teams about secure coding practices specific to Cypher and graph database interactions. 8. Maintain an incident response plan to quickly address any detected exploitation attempts.

Description

Cypher Injection vulnerability in Apache Camel camel-neo4j component. This issue affects Apache Camel: from 4.10.0 before 4.10.8, from 4.14.0 before 4.14.3, from 4.15.0 before 4.17.0 Users are recommended to upgrade to version 4.10.8 for 4.10.x LTS and 4.14.3 for 4.14.x LTS and 4.17.0.

References

Community reviews

Loading reviews…