Skip to main content
CVE-2025-66214VulnerabilityPublished

CVE-2025-66214: wearefrank ladybug · Deserialization of Untrusted Data

Affects wearefrank ladybugSource CVE Database V5

0

Not known to be exploited · CVSS 7.0 High : upgrade to 3.0-20251107.114628 soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
7.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0-20251107.114628
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade wearefrank/ladybug to 3.0-20251107.114628.

Affected software

ProductAffectedFixed in
GitHubwearefrank/ladybugpkg:github/wearefrank/ladybugOther threatsAffected
  • <3.0-20251107.114628
Fixed in
  • 3.0-20251107.114628

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Upgrade Ladybug to version 3.0-20251107.114628 or later immediately to apply the official fix. 2. Restrict network access to the vulnerable APIs (/iaf/ladybug/api/report/{storage} and /iaf/ladybug/api/report/upload) by implementing strict firewall rules or network segmentation to limit exposure to trusted users only. 3. Implement strong authentication and authorization controls around the Ladybug service to prevent unauthorized access, even within internal networks. 4. Monitor logs for unusual or unexpected XML upload activity, especially gzip-compressed payloads, and set up alerts for suspicious patterns indicative of exploitation attempts. 5. Conduct code reviews and security testing on any custom integrations with Ladybug to ensure no additional deserialization vulnerabilities exist. 6. Educate development and operations teams about the risks of deserializing untrusted data and encourage secure coding practices. 7. If patching is delayed, consider disabling or isolating the vulnerable APIs temporarily to prevent exploitation. 8. Employ runtime application self-protection (RASP) or web application firewalls (WAF) with rules targeting XML deserialization attacks as an additional defense layer.

Description

CVE-2025-66214 is a high-severity vulnerability in the wearefrank Ladybug Java debugging and testing tool, affecting versions prior to 3.0-20251107.114628. The flaw arises from unsafe deserialization of user-uploaded gzip-compressed XML files via the /iaf/ladybug/api/report/{storage} and /iaf/ladybug/api/report/upload APIs. Exploiting this vulnerability allows an attacker with low privileges and no user interaction to execute remote code on the server, potentially compromising confidentiality, integrity, and availability. The vulnerability requires local access (AV:L) and high attack complexity (AC:H), but it leads to a scope change (S:C) and significant data confidentiality impact (C:H). No known exploits are currently reported in the wild. European organizations using Ladybug for Java application testing should prioritize upgrading to version 3.0-20251107.114628 or later to mitigate this risk.

References

Community reviews

Loading reviews…