Skip to main content
CVE-2025-66222VulnerabilityPublished

CVE-2025-66222: ThinkInAIXYZ deepchat · Code Injection

Affects ThinkInAIXYZ deepchatSource CVE Database V5

0

Not known to be exploited · CVSS 9.7 Critical : upgrade to 0.5.0 as a priority.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
9.7Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.5.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade thinkinaixyz/deepchat to 0.5.0.

Affected software

ProductAffectedFixed in
GitHubthinkinaixyz/deepchatpkg:github/thinkinaixyz/deepchatOther threatsAffected
  • <0.5.0
Fixed in
  • 0.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. 2. If you cannot patch yet, disable or restrict the Mermaid diagram rendering feature to prevent injection of malicious scripts. 3. Harden Electron IPC communication by implementing strict validation and sanitization of messages, and consider disabling or sandboxing the IPC bridge if feasible. 4. Employ Content Security Policy (CSP) headers or equivalent controls to limit execution of unauthorized scripts within the application context. 5. Monitor application logs and network traffic for unusual MCP server registrations or unexpected IPC activity. 6. Educate users about the risks of interacting with untrusted content within DeepChat to reduce the likelihood of user interaction-based exploitation. 7. Implement network segmentation and endpoint protection to contain potential compromises. 8. Engage with ThinkInAIXYZ for timely updates and security advisories. 9. Consider deploying runtime application self-protection (RASP) or endpoint detection and response (EDR) solutions to detect exploitation attempts in real time.

Description

CVE-2025-66222 is a critical vulnerability in ThinkInAIXYZ's DeepChat versions prior to 0.5.0, involving a stored Cross-Site Scripting (XSS) flaw in the Mermaid diagram renderer. This XSS vulnerability allows attackers to execute arbitrary JavaScript within the application context. Exploiting the exposed Electron IPC bridge, attackers can escalate this to Remote Code Execution (RCE) by registering and starting a malicious Model Context Protocol (MCP) server. The vulnerability has a CVSS score of 9.7, indicating high impact on confidentiality, integrity, and availability without requiring privileges but needing user interaction. European organizations using DeepChat in sensitive environments face significant risks including data breaches, system compromise, and operational disruption. Mitigation requires immediate upgrading beyond version 0.5.

References

Community reviews

Loading reviews…