Skip to main content
VulnerabilityPublished

CVE-2025-66249: Apache Livy · Path Traversal

Affects Apache LivySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium : upgrade to 0.9.0-incubating when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.9.0-incubating, 0.9.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Apache Livy and Apache Software Foundation/org.apache.livy:livy-server to 0.9.0-incubating; org.apache.livy/livy-server to 0.9.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache LivyAffected
  • >=0.3.0-incubating <0.9.0-incubating
Fixed in
  • 0.9.0-incubating
MavenApache Software Foundation/org.apache.livy:livy-serverpkg:maven/Apache Software Foundation/org.apache.livy:livy-serverOther threatsAffected
  • >=0.3.0-incubating <0.9.0-incubating
Fixed in
  • 0.9.0-incubating
Mavenorg.apache.livy/livy-serverpkg:maven/org.apache.livy/livy-serverOther threatsAffected
  • <0.9.0
Fixed in
  • 0.9.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary mitigation is to upgrade Apache Livy to version 0.9.0 or later, where the vulnerability is fixed. Organizations should audit their Livy server configurations to identify any use of non-default 'livy.file.local-dir-whitelist' settings and revert to default if upgrading is not immediately possible. Additionally, implement strict access controls and network segmentation to limit exposure of Livy servers to trusted users and networks only. Monitoring and logging access to Livy file operations can help detect suspicious activity attempting path traversal. Employing file integrity monitoring on critical files can alert administrators to unauthorized access or changes. Finally, ensure that sensitive data on Livy servers is encrypted at rest and that least privilege principles are applied to service accounts to minimize damage if a breach occurs.

Description

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache Livy. This issue affects Apache Livy: from 0.3.0 before 0.9.0. The vulnerability can only be exploited with non-default Apache Livy Server settings. If the configuration value "livy.file.local-dir-whitelist" is set to a non-default value, the directory checking can be bypassed. Users are recommended to upgrade to version 0.9.0, which fixes the issue.

References

Community reviews

Loading reviews…