Skip to main content
VulnerabilityPublished

CVE-2025-66308: getgrav grav · Cross-site Scripting

Affects getgrav gravSource CVE Database V5

0

Not known to be exploited · CVSS 6.8 Medium · fixed in 1.11.0 : update getgrav grav when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.11.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:A/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
GitHubgetgrav/gravpkg:github/getgrav/gravOther threatsAffected
  • =1.11.0-beta.1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should promptly update Grav CMS to version 1.11.0-beta.1 or later to remediate this vulnerability. Additionally, implement strict access controls to limit administrative interface exposure, such as IP whitelisting, VPN access, or multi-factor authentication for admin users. Regularly audit and sanitize all user inputs, especially in configuration endpoints, to prevent injection of malicious scripts. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in browsers. Monitor logs for unusual activity around the /admin/config/site endpoint and review stored taxonomy data for suspicious content. Educate administrators on the risks of clicking unknown links or opening untrusted pages within the admin interface. Finally, conduct periodic security assessments and penetration tests focusing on web application vulnerabilities to detect similar issues proactively.

Description

This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a Stored Cross-Site Scripting (XSS) vulnerability was identified in the /admin/config/site endpoint of the Grav application. This vulnerability allows attackers to inject malicious scripts into the data[taxonomies] parameter. The injected payload is stored on the server and automatically executed in the browser of any user who accesses the affected site configuration, resulting in a persistent attack vector. This vulnerability is fixed in 1.11.0-beta.1.

References

Community reviews

Loading reviews…