Skip to main content
VulnerabilityPublished

CVE-2025-66310: getgrav grav · Cross-site Scripting

Affects getgrav gravSource CVE Database V5

0

Not known to be exploited · CVSS 6.2 Medium · fixed in 1.11.0 : update getgrav grav when convenient.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 4.0 base score
6.2Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.11.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:L/VI:L/VA:N/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
GitHubgetgrav/gravpkg:github/getgrav/gravOther threatsAffected
  • =1.11.0-beta.1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade Grav CMS to version 1.11.0-beta.1 or later to remediate this vulnerability. In addition to patching, implement strict input validation and sanitization on all user-supplied data, especially metadata fields like data[header][template]. Employ Content Security Policy (CSP) headers to restrict script execution sources and reduce the impact of potential XSS attacks. Limit administrative access to trusted users and enforce strong authentication mechanisms, including multi-factor authentication (MFA), to reduce the risk of credential compromise. Regularly audit and monitor administrative actions and logs for suspicious behavior. Consider deploying Web Application Firewalls (WAFs) with rules targeting XSS payloads specific to Grav CMS. Educate administrators about the risks of XSS and safe content management practices. Finally, conduct periodic security assessments and penetration testing focusing on CMS components to detect similar vulnerabilities early.

Description

This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a Stored Cross-Site Scripting (XSS) vulnerability was identified in the /admin/pages/[page] endpoint of the Grav application. This vulnerability allows attackers to inject malicious scripts into the data[header][template] parameter. The script is saved within the page's frontmatter and executed automatically whenever the affected content is rendered in the administrative interface or frontend view. This vulnerability is fixed in 1.11.0-beta.1.

References

Community reviews

Loading reviews…