Skip to main content
CVE-2025-66312VulnerabilityPublished

CVE-2025-66312: getgrav grav · Cross-site Scripting

Affects getgrav gravSource CVE Database V5

0

Not known to be exploited · CVSS 6.2 Medium · fixed in 1.11.0 : update getgrav grav when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
6.2Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.11.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:L/VI:L/VA:N/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
GitHubgetgrav/gravpkg:github/getgrav/gravOther threatsAffected
  • =1.11.0-beta.1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade Grav CMS to version 1.11.0-beta.1 or later to apply the official fix. Until patching is possible, restrict access to the /admin interface using network-level controls such as VPNs, IP whitelisting, or web application firewalls (WAFs) with rules to detect and block suspicious input patterns targeting the data[readableName] parameter. Implement strict input validation and output encoding on any custom plugins or extensions interacting with Grav admin endpoints. Enforce strong authentication mechanisms, including multi-factor authentication (MFA), to reduce the risk of unauthorized access. Regularly audit user accounts and permissions to minimize the number of users with administrative privileges. Monitor web server and application logs for unusual activity related to the /admin/accounts/groups/Grupo endpoint. Educate administrators about the risks of XSS and safe browsing practices within the admin interface. Finally, consider deploying Content Security Policy (CSP) headers to limit the impact of any injected scripts.

Description

This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a Stored Cross-Site Scripting (XSS) vulnerability was identified in the /admin/accounts/groups/Grupo endpoint of the Grav application. This vulnerability allows attackers to inject malicious scripts into the data[readableName] parameter. The injected scripts are stored on the server and executed automatically whenever the affected page is accessed by users, posing a significant security risk. This vulnerability is fixed in 1.11.0-beta.1.

References

Community reviews

Loading reviews…