Skip to main content
CVE-2025-66428VulnerabilityPublished Updated

CVE-2025-66428: wordpress-toolkit · n/a

Affects wordpress-toolkitSource CVE Database V5

0

Not known to be exploited · CVSS 8.8 High : upgrade to 6.9.1 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.9.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade plesk/wordpress-toolkit to 6.9.1.

Affected software

ProductAffectedFixed in
Pleskplesk/wordpress-toolkitpkg:deb/plesk/wordpress-toolkitOther threatsAffected
  • <6.9.1
Fixed in
  • 6.9.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediately update WebPros WordPress Toolkit to version 6.9.1 or later once available to address the vulnerability. 2. Restrict network access to the WordPress Toolkit management interfaces using firewalls or VPNs to limit exposure to trusted administrators only. 3. Audit and enforce strict user privilege policies within the toolkit and underlying systems to minimize the risk of privilege escalation. 4. Monitor logs for unusual directory access patterns or privilege escalation attempts related to WordPress directories. 5. Implement file system permissions that prevent unauthorized modification or traversal of WordPress directories. 6. Consider deploying Web Application Firewalls (WAFs) with rules targeting suspicious path traversal or privilege escalation behaviors. 7. Stay informed through official WebPros security advisories for any patches or additional mitigation guidance.

Description

CVE-2025-66428 is a high-severity vulnerability in WebPros WordPress Toolkit versions prior to 6.9.1 that allows privilege escalation due to improper handling of WordPress directory names. The flaw enables attackers with limited privileges to escalate their access rights, potentially gaining full control over the affected system. The vulnerability has a CVSS score of 8.8, indicating a critical impact on confidentiality, integrity, and availability without requiring user interaction. Although no known exploits are currently in the wild, the vulnerability poses a significant risk to organizations using the affected toolkit for WordPress management. European organizations relying on WordPress Toolkit for website administration should prioritize patching to prevent exploitation. Countries with large WordPress hosting markets and significant web infrastructure, such as Germany, the United Kingdom, and France, are particularly at risk. Mitigation involves promptly updating to version 6.

References

Community reviews

Loading reviews…