Skip to main content
CVE-2025-66456VulnerabilityPublished

CVE-2025-66456: elysiajs elysia · Prototype Pollution

Affects elysiajs elysiaSource CVE Database V5

0

Not known to be exploited · CVSS 9.1 Critical : upgrade to 1.4.17 as a priority.

Data as of 26 Oct 2026, 07:57 UTC

CVSS 4.0 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.4.17
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade elysiajs/elysia to 1.4.17.

Affected software

ProductAffectedFixed in
npmelysiajs/elysiapkg:npm/elysiajs/elysiaOther threatsAffected
  • >=1.4.0 <1.4.17
Fixed in
  • 1.4.17

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediately upgrade all instances of the Elysia framework to version 1.4.17 or later, where the vulnerability is patched. 2. Implement input validation and sanitization to explicitly remove or reject any __proto__ keys in incoming JSON or request bodies before processing. 3. Employ runtime application self-protection (RASP) or web application firewalls (WAF) with custom rules to detect and block payloads attempting prototype pollution. 4. Conduct thorough code reviews and dependency audits to identify and remediate any other instances of unsafe object merging or prototype manipulation. 5. Monitor application logs and network traffic for suspicious activities indicative of exploitation attempts, especially unusual object property modifications. 6. Educate development teams on secure coding practices related to object merging and prototype pollution risks. 7. In environments where immediate patching is not feasible, consider isolating vulnerable services behind additional security layers and restricting access to trusted networks only.

Description

CVE-2025-66456 is a critical prototype pollution vulnerability in the Elysia Typescript framework versions 1.4.0 through 1.4.16. It arises from improper merging of schema validation results in the mergeDeep function, allowing an attacker to manipulate the __proto__ property. When combined with another vulnerability (GHSA-8vch-m3f4-q8jf), this can lead to full remote code execution (RCE) without authentication or user interaction. The vulnerability has a CVSS 4.0 score of 9.1, indicating high severity.

References

Community reviews

Loading reviews…