Skip to main content
CVE-2025-66580VulnerabilityPublished

CVE-2025-66580: OpenAgentPlatform Dive · Code Injection

Affects OpenAgentPlatform DiveSource CVE Database V5

0

Not known to be exploited · CVSS 9.7 Critical : upgrade to 0.11.1 as a priority.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
9.7Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.11.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade openagentplatform/Dive to 0.11.1.

Affected software

ProductAffectedFixed in
GitHubopenagentplatform/Divepkg:github/openagentplatform/DiveOther threatsAffected
  • <0.11.1
Fixed in
  • 0.11.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2025-66580, European organizations should immediately upgrade all instances of Dive to version 0.11.1 or later, which contains the necessary patches to prevent arbitrary JavaScript execution. Until upgrades are complete, restrict access to the application and disable or limit the use of Mermaid diagram rendering features, especially those that accept user-generated content. Implement strict input validation and sanitization on any data fed into Dive, particularly for MCP server configurations and diagram nodes. Educate users about the risks of clicking untrusted or unexpected nodes within diagrams to reduce the likelihood of successful social engineering. Employ endpoint protection solutions capable of detecting and blocking suspicious script execution. Monitor logs and network traffic for unusual activity related to Dive usage. Additionally, consider isolating the application environment or running it within sandboxed containers to limit the blast radius of potential exploitation. Regularly review and update security policies around open-source AI tool usage and integration.

Description

Dive is an open-source MCP Host Desktop Application that enables integration with function-calling LLMs. A critical Stored Cross-Site Scripting (XSS) vulnerability exists in versions prior to 0.11.1 in the Mermaid diagram rendering component. The application allows the execution of arbitrary JavaScript via `javascript:`. An attacker can exploit this to inject a malicious Model Context Protocol (MCP) server configuration, leading to Remote Code Execution (RCE) on the victim's machine when the node is clicked. Version 0.11.1 fixes the issue.

References

Community reviews

Loading reviews…