CVE-2025-66675: Apache Struts · Incomplete Cleanup
Affects Apache StrutsSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 8.2 High · fixed in 6.8.0 : patch Apache Struts soon.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.8.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 10 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.struts/struts2-corepkg:maven/org.apache.struts/struts2-coreOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
- Immediate upgrade of Apache Struts to versions 6.8.0 or 7.1.1 where the vulnerability is fixed.
- Implement strict resource limits on multipart request processing, such as limiting the size and number of temporary files created per request.
- Monitor disk usage closely on servers running Apache Struts to detect unusual growth in temporary files or disk consumption.
- Employ web application firewalls (WAFs) with rules to detect and block abnormal multipart/form-data requests that could trigger the vulnerability.
- Conduct regular audits of web server logs to identify patterns of multipart request abuse.
- For legacy systems that cannot be immediately upgraded, consider isolating them behind reverse proxies that can filter or rate-limit multipart requests.
- Educate development and operations teams about the vulnerability and ensure patch management processes prioritize this update.
- Review multipart request handling configurations and disable unnecessary multipart support if not required by the application.
Description
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.4, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue. It's related to https://cve.org/CVERecord?id=CVE-2025-64775 - this CVE addresses missing affected version 6.7.4