Skip to main content
VulnerabilityPublished

CVE-2025-6711: MongoDB Server · Sensitive Data in Logs

Affects MongoDB ServerSource CVE Database V5

0

Not known to be exploited · CVSS 4.4 Medium · fixed in 8.0.5 : update MongoDB Server when convenient.

Data as of 26 Oct 2026, 12:29 UTC

CVSS 3.1 base score
4.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.0.5, 7.0.18, 6.0.21
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade MongoDB Server to 8.0.5, 7.0.18 or 6.0.21.

Affected software

ProductAffectedFixed in
MongoDB Inc MongoDB ServerAffected
  • =6.0
  • =7.0
  • =8.0
  • >=6.0 <6.0.21
  • >=7.0 <7.0.18
  • >=8.0 <8.0.5
Fixed in
  • 6.0.21
  • 7.0.18
  • 8.0.5

AI-suggested

A fix is available in MongoDB Server versions 6.0.21, 7.0.18, and 8.0.5. Users should upgrade to these or later versions to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory. Patch status is confirmed by the version information specifying fixed versions.

Description

CVE-2025-6711 is a vulnerability in MongoDB Server where sensitive information from unredacted queries may be logged in server logs under certain error conditions. This affects MongoDB Server versions 6.0 prior to 6.0.21, 7.0 prior to 7.0.18, and 8.0 prior to 8.0.5. The vulnerability has a medium severity with a CVSS score of 4.4. It does not involve integrity or availability impacts but can lead to confidentiality breaches due to sensitive data exposure in logs.

References

Community reviews

Loading reviews…