CVE-2025-6713: MongoDB Server · Improper Authorization
Affects MongoDB ServerSource CVE Database V5
Not known to be exploited · CVSS 7.7 High · fixed in 8.0.7 : patch MongoDB Server soon.
Data as of 26 Oct 2026, 08:30 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.0.7, 7.0.19, 6.0.22
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 7 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade MongoDB Server to 8.0.7, 7.0.19 or 6.0.22.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MongoDB Inc MongoDB Server | Affected
| Fixed in
|
AI-suggested
A fix is available in MongoDB Server versions 6.0.22, 7.0.19, and 8.0.7. Users should upgrade to these or later versions to remediate the vulnerability. No additional mitigation steps are indicated.
Description
CVE-2025-6713 is a high-severity vulnerability in MongoDB Server that allows unauthorized users to access data without proper authorization. The flaw arises from improper handling of the $mergeCursors stage in aggregation pipelines. This affects MongoDB Server versions 6.0 prior to 6.0.22, 7.0 prior to 7.0.19, and 8.0 prior to 8.0.7.