Skip to main content
VulnerabilityPublished Updated

CVE-2025-67848: moodle · Improper Handling of Insufficient Permissions or Privileges

Affects moodleSource CVE Database V5

0

Not known to be exploited · CVSS 8.1 High · fixed in 5.1.1 : patch moodle soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.1.1, 5.0.4, 4.5.8 +2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Packagistmoodle/moodlepkg:composer/moodle/moodleOther threatsAffected
  • 4.1.0 – 5.1.0
5 affected builds
Fixed in–
GitHubmoodlepkg:github/moodleOther threatsAffected
  • >=4.1.0 <4.1.22
  • >=4.4.0 <4.4.12
  • >=4.5.0 <4.5.8
  • >=5.0.0 <5.0.4
  • >=5.1.0 <5.1.1
Fixed in
  • 4.1.22
  • 4.4.12
  • 4.5.8
  • 5.0.4
  • 5.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Immediate application of security patches or updates from Moodle once available is the most effective mitigation.
  2. If you cannot patch yet, organizations should disable or restrict the use of the LTI Provider authentication method, especially for suspended users.
  3. Implement additional access control checks at the application or network level to block authentication attempts from suspended accounts.
  4. Monitor authentication logs for unusual login attempts from suspended users and investigate anomalies promptly.
  5. Employ multi-factor authentication (MFA) to add an additional layer of verification, reducing the risk of unauthorized access.
  6. Conduct a thorough review of user suspension and account management policies to ensure proper enforcement.
  7. Educate administrators and users about the vulnerability and encourage prompt reporting of suspicious activities.
  8. Consider network segmentation and limiting external access to Moodle instances to reduce exposure. These steps go beyond generic advice by focusing on specific controls around LTI authentication and suspended user management.

Description

A flaw was found in Moodle. This authentication bypass vulnerability allows suspended users to authenticate through the Learning Tools Interoperability (LTI) Provider. The issue arises from the LTI authentication handlers failing to enforce the user's suspension status, enabling unauthorized access to the system. This can lead to information disclosure or other unauthorized actions by users who should be restricted.

References

Community reviews

Loading reviews…