Skip to main content
CVE-2025-67849VulnerabilityPublished Updated

CVE-2025-67849: moodle · Cross-site Scripting

Affects moodleSource CVE Database V5

0

Not known to be exploited · CVSS 7.3 High · fixed in 5.1.1 : patch moodle soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.1.1, 5.0.4, 4.5.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade moodle to 5.1.1, 5.0.4 or 4.5.8.

Affected software

ProductAffectedFixed in
Packagistmoodle/moodlepkg:composer/moodle/moodleOther threatsAffected
  • =4.5.0
  • =5.0.0
  • =5.1.0
Fixed in–
GitHubmoodlepkg:github/moodleOther threatsAffected
  • >=4.5.0 <4.5.8
  • >=5.0.0 <5.0.4
  • >=5.1.0 <5.1.1
Fixed in
  • 4.5.8
  • 5.0.4
  • 5.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2025-67849, organizations should immediately upgrade Moodle to patched versions once available. In the absence of patches, administrators should implement strict input validation and output encoding on all AI prompt responses before rendering them in web pages. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts and reduce the impact of XSS attacks. Limit user privileges to the minimum necessary to reduce the risk of malicious input submission. Monitor logs for unusual activities related to AI prompt inputs and user session anomalies. Educate users about the risks of interacting with suspicious content and encourage the use of multi-factor authentication to protect accounts from hijacking. Additionally, consider disabling or restricting AI prompt features temporarily if they cannot be secured promptly. Regular security assessments and penetration testing focused on AI integration points can help identify and remediate similar vulnerabilities proactively.

Description

A flaw was found in Moodle. This cross-site scripting (XSS) vulnerability, caused by improper sanitization of AI prompt responses, allows attackers to inject malicious HTML or script into web pages. When other users view these compromised pages, their sessions could be stolen, or the user interface could be manipulated.

References

Community reviews

Loading reviews…