Skip to main content
CVE-2025-67850VulnerabilityPublished Updated

CVE-2025-67850: moodle · Cross-site Scripting

Affects moodleSource CVE Database V5

0

Not known to be exploited · CVSS 7.3 High · fixed in 5.1.1 : patch moodle soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.1.1, 5.0.4, 4.5.8 +2
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Packagistmoodle/moodlepkg:composer/moodle/moodleOther threatsAffected
  • =4.1.0
  • =4.4.0
  • =4.5.0
  • =5.0.0
  • =5.1.0
Fixed in–
GitHubmoodlepkg:github/moodleOther threatsAffected
  • >=4.1.0 <4.1.22
  • >=4.4.0 <4.4.12
  • >=4.5.0 <4.5.8
  • >=5.0.0 <5.0.4
  • >=5.1.0 <5.1.1
Fixed in
  • 4.1.22
  • 4.4.12
  • 4.5.8
  • 5.0.4
  • 5.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2025-67850, organizations should prioritize updating Moodle to a patched version once available from the vendor. In the absence of immediate patches, administrators can implement strict input validation and output encoding on the formula editor's arithmetic expression fields to neutralize malicious scripts. Restricting the ability to input arithmetic expressions to trusted users or roles can reduce exposure. Additionally, enabling Content Security Policy (CSP) headers can help limit the impact of injected scripts by restricting the sources from which scripts can be loaded and executed. Regularly auditing user-generated content for suspicious scripts and educating users about the risks of interacting with untrusted content can further reduce exploitation chances. Monitoring logs for unusual activities related to the formula editor and user sessions can help detect attempted attacks. Finally, applying the principle of least privilege to user roles in Moodle minimizes the number of users who can inject potentially malicious content.

Description

A flaw was found in moodle. This vulnerability, known as Cross-Site Scripting (XSS), occurs due to insufficient checks on user-provided data in the formula editor's arithmetic expression fields. A remote attacker could inject malicious code into these fields. When other users view these expressions, the malicious code would execute in their web browsers, potentially compromising their data or leading to unauthorized actions.

References

Community reviews

Loading reviews…