Skip to main content
CVE-2025-67855VulnerabilityPublished

CVE-2025-67855: mooodle · Cross-site Scripting

Affects mooodleSource CVE Database V5

0

Not known to be exploited · CVSS 5.4 Medium · fixed in 5.1.1 : update mooodle when convenient.

Data as of 26 Oct 2026, 06:15 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.1.1, 5.0.4, 4.5.8 +2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Red Hatredhat/mooodlepkg:rpm/redhat/mooodleOther threatsAffected
  • =4.1.0
  • =4.4.0
  • =4.5.0
  • =5.0.0
  • =5.1.0
Fixed in–
GitHubmoodlepkg:github/moodleOther threatsAffected
  • >=4.1.0 <4.1.22
  • >=4.4.0 <4.4.12
  • >=4.5.0 <4.5.8
  • >=5.0.0 <5.0.4
  • >=5.1.0 <5.1.1
Fixed in
  • 4.1.22
  • 4.4.12
  • 4.5.8
  • 5.0.4
  • 5.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately verify if their Moodle installations are running affected versions (4.1.0 through 5.1.0) and prioritize upgrading to patched versions once available. In the absence of official patches, administrators should implement input validation and output encoding on URL parameters, especially those used in the policy tool return URL, to neutralize malicious scripts. Employing a Content Security Policy (CSP) can help restrict the execution of unauthorized scripts in browsers. Additionally, educating users about the risks of clicking untrusted links and implementing web application firewalls (WAFs) with rules to detect and block reflected XSS payloads can reduce exploitation likelihood. Monitoring logs for suspicious URL parameters and anomalous user activity can aid in early detection. Regular security assessments and penetration testing focused on web application vulnerabilities should be conducted. Finally, ensure that session cookies are flagged as HttpOnly and Secure to mitigate session theft risks.

Description

A flaw was found in mooodle. A remote attacker could exploit a reflected Cross-Site Scripting (XSS) vulnerability in the policy tool return URL. This vulnerability arises from insufficient sanitization of URL parameters, allowing attackers to inject malicious scripts through specially crafted links. Successful exploitation could lead to information disclosure or arbitrary client-side script execution within the user's browser.

References

Community reviews

Loading reviews…