Skip to main content
CVE-2025-68399VulnerabilityPublished

CVE-2025-68399: ChurchCRM CRM · Cross-site Scripting

Affects ChurchCRM CRMSource CVE Database V5

0

Not known to be exploited · CVSS 2.0 Low : upgrade to 6.5.4 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
2.0Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.5.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade churchcrm/CRM to 6.5.4.

Affected software

ProductAffectedFixed in
GitHubchurchcrm/CRMpkg:github/churchcrm/CRMOther threatsAffected
  • <6.5.4
Fixed in
  • 6.5.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade ChurchCRM installations to version 6.5.4 or later to remediate the vulnerability. Until the upgrade is applied, restrict group modification permissions strictly to trusted users and monitor for unusual activity involving group role creation. Implement web application firewalls (WAFs) with rules to detect and block common XSS payloads targeting the GroupEditor.php endpoint. Conduct regular security audits and user permission reviews to minimize the attack surface. Educate users with elevated privileges about the risks of XSS and the importance of cautious input handling. Additionally, consider implementing Content Security Policy (CSP) headers to reduce the impact of potential XSS attacks by restricting script execution sources.

Description

ChurchCRM is an open-source church management system. In versions prior to 6.5.4, there is a Stored Cross-Site Scripting (XSS) vulnerability within the GroupEditor.php page of the application. When a user attempts to create a group role, they can execute malicious JavaScript. However, for this to work, the user must have permission to view and modify groups in the application. Version 6.5.4 fixes the issue.

References

Community reviews

Loading reviews…