CVE-2025-68455: craftcms cms · Unsafe Reflection
Affects craftcms cmsSource CVE Database V5
Not known to be exploited · CVSS 8.6 High : upgrade to 5.8.21 or 4.16.17 soon.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.8.21, 4.16.17
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 5 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade craftcms cms to 5.8.21 or 4.16.17.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| craftcmscms | Affected
| Fixed in
|
| craftcmscms | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
- Immediately upgrade Craft CMS installations to versions 4.16.17 or 5.8.21 or later, which contain the security fix for this vulnerability.
- Enforce strict access controls and multi-factor authentication (MFA) for all administrator accounts to reduce the risk of credential compromise.
- Regularly audit and monitor administrator activities within the Craft Control Panel for unusual or unauthorized Behavior attachments or code changes.
- Implement network segmentation and limit administrative access to trusted IP addresses or VPNs to reduce exposure.
- Conduct security awareness training focused on phishing and credential security to protect administrator accounts.
- Review and restrict the use of Behaviors in the CMS, ensuring only trusted and necessary extensions are enabled.
- Employ runtime application self-protection (RASP) or web application firewalls (WAF) with custom rules to detect and block suspicious code execution patterns related to this vulnerability.
- Maintain regular backups and incident response plans to quickly recover from potential exploitation.
Description
CVE-2025-68455 is a high-severity vulnerability in Craft CMS versions 4.0.0-RC1 through 4.16.16 and 5.0.0-RC1 through 5.8.20, allowing authenticated administrators to execute remote code via maliciously crafted Behaviors. The flaw arises from unsafe reflection (CWE-470), where externally controlled input is used to select classes or code, enabling potential Remote Code Execution (RCE).
References
- github.com/craftcms/cms/security/advisories/GHSA-255j-qw47-wjh5 (opens in a new tab)
- github.com/craftcms/cms/commit/27f55886098b56c00ddc53b69239c9c9192252c7 (opens in a new tab)
- github.com/craftcms/cms/commit/6e608a1a5bfb36943f94f584b7548ca542a86fef (opens in a new tab)
- github.com/craftcms/cms/commit/ec43c497edde0b2bf2e39a119cded2e55f9fe593 (opens in a new tab)
- github.com/craftcms/cms/blob/5.x/CHANGELOG.md (opens in a new tab)