Skip to main content
CVE-2025-68701VulnerabilityPublished

CVE-2025-68701: samrocketman jervis · Weak Cryptography

Affects samrocketman jervisSource CVE Database V5

0

Not known to be exploited · CVSS 8.7 High : upgrade to 2.2 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade jervis and samrocketman/jervis to 2.2.

Affected software

ProductAffectedFixed in
samrocketmanjervisAffected
  • <2.2
Fixed in
  • 2.2
GitHubsamrocketman/jervispkg:github/samrocketman/jervisOther threatsAffected
  • <2.2
Fixed in
  • 2.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary and most effective mitigation is to upgrade the Jervis library to version 2.2 or later, where the deterministic IV derivation flaw is corrected. Organizations should audit their Jenkins environments to identify usage of Jervis and verify the version in use. Additionally, security teams should review all cryptographic implementations within Jenkins pipelines to ensure adherence to best practices, including the use of random, unique IVs for AES encryption and secure key management. Implementing monitoring and alerting for unusual access patterns or data exfiltration attempts related to Jenkins pipelines is advisable. Where upgrading is not immediately possible, organizations should consider isolating Jenkins environments, restricting network access, and applying compensating controls such as encrypting sensitive data at rest with external tools that use secure cryptography. Finally, educating DevOps and security teams about cryptographic hygiene and secure pipeline design will help prevent similar issues.

Description

CVE-2025-68701 is a high-severity cryptographic vulnerability in the Jervis library used for Jenkins Job DSL and shared pipeline scripts. Versions prior to 2.2 use a deterministic AES initialization vector (IV) derived from a passphrase, which weakens encryption by making ciphertext patterns predictable and susceptible to cryptanalysis. This flaw allows attackers to potentially recover sensitive data or compromise the confidentiality of encrypted information without requiring authentication or user interaction. The vulnerability has a CVSS 4.0 base score of 8.7, indicating a network-exploitable issue with high impact on confidentiality. The issue is fixed in Jervis version 2.2. European organizations relying on Jenkins automation with Jervis versions before 2.

References

Community reviews

Loading reviews…