CVE-2025-68951: thorsten phpMyFAQ · Cross-site Scripting
Affects thorsten phpMyFAQSource CVE Database V5
Not known to be exploited · CVSS 5.4 Medium · fixed in 4.0.16 : update thorsten phpMyFAQ when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.0.16
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubthorsten/phpMyFAQpkg:github/thorsten/phpMyFAQOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should promptly upgrade phpMyFAQ to version 4.0.16 or later, where the vulnerability is patched. Until the upgrade is applied, organizations can implement strict input validation and output encoding on user-supplied data, especially display names, to prevent HTML entity injection. Restricting registration capabilities or implementing CAPTCHA and email verification can reduce the risk of automated malicious registrations. Administrators should be cautious when viewing the user list and consider limiting access to this page to trusted personnel only. Employing Content Security Policy (CSP) headers can help mitigate the impact of XSS by restricting script execution sources. Regularly monitoring logs for suspicious user registrations or unusual admin page access patterns can help detect exploitation attempts. Finally, educating administrators about the risk and signs of XSS attacks will improve incident response readiness.
Description
phpMyFAQ is an open source FAQ web application. Versions 4.0.14 and 4.0.15 have a stored cross-site scripting (XSS) vulnerability that allows an attacker to execute arbitrary JavaScript in an administrator’s browser by registering a user whose display name contains HTML entities. When an administrator views the admin user list, the payload is decoded server-side and rendered without escaping, resulting in script execution in the admin context. Version 4.0.16 contains a patch for the issue.