CVE-2025-69662: geopandas · SQL Injection
Affects geopandasSource CVE Database V5
Not known to be exploited · CVSS 8.6 High : upgrade to 1.1.2 soon.
Data as of 26 Oct 2026, 12:55 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.1.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade geopandas to 1.1.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
PyPIgeopandaspkg:pypi/geopandasOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade to geopandas version 1.1.2 or later once available or apply any official fixes provided by the vendor. Until a patch is confirmed, avoid using the to_postgis() function with untrusted input or implement additional input validation and query parameterization as a temporary mitigation.
Description
SQL injection vulnerability in geopandas before v.1.1.2 allows an attacker to obtain sensitive information via the to_postgis()` function being used to write GeoDataFrames to a PostgreSQL database.