CVE-2025-7195: operator-sdk · Incorrect Default Permissions
Affects operator-sdkSource CVE Database V5
Not known to be exploited · CVSS 6.4 Medium : upgrade to 0.15.2 when convenient.
Data as of 26 Oct 2026, 09:16 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.15.2
CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade operator-sdk to 0.15.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| operator-frameworkoperator-sdk | Affected
| Fixed in
|
GitHuboperator-sdkpkg:github/operator-sdkOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
An official fix is available in Operator-SDK version 0.15.2 and later. Users and developers should upgrade to version 0.15.2 or newer to eliminate the insecure user_setup script. For existing containers built with earlier versions, rebuild container images using the updated Operator-SDK to ensure correct permissions on /etc/passwd. Follow vendor advisories and update affected components accordingly.
Description
Early versions of Operator-SDK provided an insecure method to allow operator containers to run in environments that used a random UID. Operator-SDK before 0.15.2 provided a script, user_setup, which modifies the permissions of the /etc/passwd file to 664 during build time. Developers who used Operator-SDK before 0.15.2 to scaffold their operator may still be impacted by this if the insecure user_setup script is still being used to build new container images. In affected images, the /etc/passwd file is created during build time with group-writable permissions and a group ownership of root (gid=0). An attacker who can execute commands within an affected container, even as a non-root user, may be able to leverage their membership in the root group to modify the /etc/passwd file. This could allow the attacker to add a new user with any arbitrary UID, including UID 0, leading to full root privileges within the container.
References
- access.redhat.com/errata/RHEA-2025:23406 (opens in a new tab)
- access.redhat.com/errata/RHEA-2025:23478 (opens in a new tab)
- access.redhat.com/errata/RHEA-2026:0129 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:19332 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:19335 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:19958 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:19961 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:21368 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:21885 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:22415 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:22416 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:22418 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:22420 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:22683 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:22684 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:23528 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:23529 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:23542 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:0627 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:0718 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:0722 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:0737 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:2572 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:5633 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-7195 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2376300 (opens in a new tab)