Skip to main content
VulnerabilityPublished

CVE-2025-8046: Injection Guard (WordPress plugin) · Cross-Site Scripting (XSS)

Affects Injection Guard (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium · fixed in 1.2.8 : update Injection Guard (WordPress plugin) when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.2.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Injection GuardAffected
  • =0
Fixed in–

AI-suggested

European organizations should take the following specific mitigation steps: 1) Immediately audit WordPress sites to identify the presence and version of the Injection Guard plugin. 2) Upgrade the Injection Guard plugin to version 1.2.8 or later as soon as it becomes available, as this version addresses the escaping issue. 3) Implement Web Application Firewall (WAF) rules that detect and block suspicious URL parameters containing script payloads targeting the REQUEST_URI parameter. 4) Educate users and administrators about the risks of clicking untrusted links, especially those that appear in emails or external communications. 5) Encourage or enforce the use of modern browsers with built-in XSS protections among users. 6) Employ Content Security Policy (CSP) headers to restrict the execution of inline scripts and reduce the impact of potential XSS attacks. 7) Monitor web server and application logs for unusual requests that may indicate attempted exploitation. 8) Consider deploying security plugins or modules that sanitize and validate URL parameters before processing. These targeted actions go beyond generic advice by focusing on plugin version management, user awareness, and layered defenses tailored to the nature of this reflected XSS vulnerability.

Description

The Injection Guard WordPress plugin before 1.2.8 does not escape the $_SERVER['REQUEST_URI'] parameter before outputting it back in an attribute, which could lead to Reflected Cross-Site Scripting in old web browsers

References

Community reviews

Loading reviews…