Skip to main content
CVE-2025-8262VulnerabilityPublished

CVE-2025-8262: yarnpkg Yarn · ReDoS

Affects yarnpkg YarnSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
npmyarnpkg:npm/yarnOther threatsAffected
  • =1.22.0
  • =1.22.1
  • =1.22.2
  • =1.22.3
  • =1.22.4
  • =1.22.5
  • =1.22.6
  • =1.22.7
  • =1.22.8
  • =1.22.9
  • =1.22.10
  • =1.22.11
  • =1.22.12
  • =1.22.13
  • =1.22.14
  • =1.22.15
  • =1.22.16
  • =1.22.17
  • =1.22.18
  • =1.22.19
  • =1.22.20
  • =1.22.21
  • =1.22.22
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2025-8262, European organizations should take the following specific actions: 1) Immediately identify all instances of Yarn versions 1.22.0 through 1.22.22 in use across development, testing, and production environments. 2) Apply the official patch referenced by commit 97731871e674bf93bcbf29e9d3258da8685f3076 or upgrade to a fixed Yarn version beyond 1.22.22 that includes the remediation. 3) Implement input validation and sanitization controls where possible to detect and block maliciously crafted inputs targeting the hosted-git resolver functionality. 4) Monitor resource usage patterns on systems running Yarn to detect anomalous CPU spikes indicative of exploitation attempts. 5) Restrict network exposure of systems running vulnerable Yarn instances, especially those accessible from untrusted networks, to reduce remote attack surface. 6) Integrate vulnerability scanning and dependency management tools into CI/CD pipelines to automatically detect and remediate vulnerable Yarn versions. 7) Educate development and operations teams about the risks of inefficient regular expression vulnerabilities and encourage best practices in dependency management. These targeted measures go beyond generic advice by focusing on patch management, exposure reduction, and proactive monitoring specific to this vulnerability's characteristics.

Description

A vulnerability was found in yarnpkg Yarn up to 1.22.22. It has been classified as problematic. Affected is the function explodeHostedGitFragment of the file src/resolvers/exotics/hosted-git-resolver.js. The manipulation leads to inefficient regular expression complexity. It is possible to launch the attack remotely. The patch is identified as 97731871e674bf93bcbf29e9d3258da8685f3076. It is recommended to apply a patch to fix this issue.

References

Community reviews

Loading reviews…