CVE-2025-8264: z-push/z-push-dev · SQL Injection
Affects z-push/z-push-devSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 2.7.6 as a priority.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.7.6
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:H/E:PExploitation evidence
Disclosed: evidence found.
CVE published 29 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade z-push/z-push-dev to 2.7.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubz-push/z-push-devpkg:github/z-push/z-push-devOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available by upgrading to version 2.7.6 or later. Alternatively, users can mitigate the vulnerability by changing the IMAP backend configuration in backend/imap/config.php to use the default or LDAP backend instead of the IMAP_FROM_SQL_QUERY option. Specifically, define 'IMAP_DEFAULTFROM' as '' (empty) or 'ldap'.
Description
Versions of the package z-push/z-push-dev before 2.7.6 are vulnerable to SQL Injection due to unparameterized queries in the IMAP backend. An attacker can inject malicious commands by manipulating the username field in basic authentication. This allows the attacker to access and potentially modify or delete sensitive data from a linked third-party database. **Note:** This vulnerability affects Z-Push installations that utilize the IMAP backend and have the IMAP_FROM_SQL_QUERY option configured. Mitigation Change configuration to use the default or LDAP in backend/imap/config.php php define('IMAP_DEFAULTFROM', ''); or php define('IMAP_DEFAULTFROM', 'ldap');
References
- security.snyk.io/vuln/SNYK-PHP-ZPUSHZPUSHDEV-10908180 (opens in a new tab)
- xbow.com/blog/xbow-zpush-sqli/ (opens in a new tab)
- github.com/Z-Hub/Z-Push/pull/161/commits/f981d515a35ac4c303959af21dce880a5db02786 (opens in a new tab)
- github.com/Z-Hub/Z-Push/pull/161 (opens in a new tab)
- github.com/Z-Hub/Z-Push/blob/af25a2169a50d6e05a5916d1e8b2b6cd17011c98/src/backend/imap/user_identity.php%23L211C9-L214C25 (opens in a new tab)