CVE-2025-8521: givanz Vvveb · Cross-site Scripting
Affects givanz VvvebSource CVE Database V5
Public exploit available · CVSS 4.8 Medium · fixed in 1.0.6 : patch givanz Vvveb as a priority.
Data as of 26 Oct 2026, 11:42 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.0.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 4 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| givanz Vvveb | Affected
| Fixed in– |
AI-suggested
- Immediate upgrade to givanz Vvveb version 1.0.6, which contains the official patch addressing this XSS vulnerability.
- Implement strict Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in the web application context.
- Conduct thorough input validation and sanitization on all user-supplied data, especially in the affected module handling post-types.
- Employ web application firewalls (WAFs) configured to detect and block typical XSS attack patterns targeting the /vadmin123/index.php endpoint.
- Monitor web server logs for unusual requests or patterns indicative of exploitation attempts, such as suspicious query parameters or script injections.
- Educate users and administrators about the risks of clicking on untrusted links or executing unknown scripts within the application interface.
- Regularly review and update security policies and incident response plans to include scenarios involving XSS attacks. These steps, combined with the patch, will significantly reduce the risk of exploitation and limit potential damage.
Description
A vulnerability, which was classified as problematic, has been found in givanz Vvveb up to 1.0.5. This issue affects some unknown processing of the file /vadmin123/index.php?module=settings/post-types of the component Add Type Handler. The manipulation leads to cross site scripting. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.0.6 is able to address this issue. The patch is named b53c7161da606f512b7efcb392d6ffc708688d49/605a70f8729e4d44ebe272671cb1e43e3d6ae014. It is recommended to upgrade the affected component.