Skip to main content
CVE-2025-8549VulnerabilityPublished

CVE-2025-8549: atjiu pybbs · Weak Password Requirements

Affects atjiu pybbsSource CVE Database V5

0

Not known to be exploited · CVSS 6.3 Medium.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
atjiu pybbsAffected
  • =6.0
Fixed in–

AI-suggested

European organizations should prioritize applying the official patch identified by commit d09cb19a8e7d7e5151282926ada54080244d499f to upgrade pybbs beyond version 6.0.0. In addition to patching, organizations should enforce strong password policies at the application and organizational level, including minimum length, complexity requirements, and periodic password changes. Implement multi-factor authentication (MFA) for administrative and user accounts to reduce the risk of unauthorized access even if weak passwords are set. Conduct regular security audits and penetration testing focusing on authentication mechanisms. Monitor logs for unusual password change activities or failed login attempts to detect potential exploitation attempts early. Finally, educate users and administrators about the risks of weak passwords and the importance of secure credentials.

Description

A vulnerability was found in atjiu pybbs up to 6.0.0. It has been classified as critical. Affected is the function update of the file src/main/java/co/yiiu/pybbs/controller/admin/UserAdminController.java. The manipulation leads to weak password requirements. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. The patch is identified as d09cb19a8e7d7e5151282926ada54080244d499f. It is recommended to apply a patch to fix this issue.

References

Community reviews

Loading reviews…