Skip to main content
CVE-2025-8715VulnerabilityPublished Updated

CVE-2025-8715: PostgreSQL · CRLF Injection

Affects PostgreSQLSource CVE Database V5

0

Mentioned vulnerabilities

Not known to be exploited · CVSS 8.8 High.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
PostgreSQLAffected
  • =17
  • =16
  • =15
  • =14
  • =11.20
Fixed in–

AI-suggested

To mitigate CVE-2025-8715, organizations should immediately upgrade PostgreSQL installations to the fixed versions 17.6, 16.10, 15.14, 14.19, or 13.22 once they are released. Until patches are applied, restrict access to the origin PostgreSQL servers to trusted users only, minimizing the risk of malicious dump file creation. Validate and sanitize all object names and metadata before performing dump operations to detect suspicious characters or sequences. Avoid restoring dump files from untrusted or unknown sources. Implement strict operational controls around backup and restore procedures, including running restore operations under least-privileged OS accounts to limit potential damage from code execution. Monitor logs for unusual psql meta-command activity during restores. Employ network segmentation to isolate backup and restore environments. Consider using containerized or sandboxed environments for restore operations to contain potential exploits. Regularly audit PostgreSQL configurations and user privileges to reduce attack surface. Finally, educate database administrators about this vulnerability and the risks of restoring untrusted dumps.

Description

Improper neutralization of newlines in pg_dump in PostgreSQL allows a user of the origin server to inject arbitrary code for restore-time execution as the client operating system account running psql to restore the dump, via psql meta-commands inside a purpose-crafted object name. The same attacks can achieve SQL injection as a superuser of the restore target server.pg_dumpall, pg_restore, and pg_upgrade are also affected. Versions before PostgreSQL 17.6, 16.10, 15.14, 14.19, and 13.22 are affected. Versions before 11.20 are unaffected. CVE-2012-0868 had fixed this class of problem, but version 11.20 reintroduced it.

References

Community reviews

Loading reviews…