Skip to main content
CVE-2025-8812VulnerabilityPublished Updated

CVE-2025-8812: atjiu pybbs · Cross Site Scripting

Affects atjiu pybbsSource CVE Database V5

0

Not known to be exploited · CVSS 4.8 Medium.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Affected software

ProductAffectedFixed in
atjiu pybbsAffected
  • =6.0
Fixed in–

AI-suggested

Organizations should immediately apply the official patch identified by commit 2fe4a51afbce0068c291bc1818bbc8f7f3b01a22 to update pybbs to a secure version beyond 6.0.0. In addition to patching, administrators should implement strict Content Security Policies (CSP) to restrict script execution and reduce XSS impact. Input validation and output encoding should be reviewed and enhanced in custom integrations or plugins. Access to the Admin Panel should be restricted via network controls such as IP whitelisting or VPN access to limit exposure. Multi-factor authentication (MFA) for admin accounts can mitigate session hijacking risks. Regular security audits and monitoring of web logs for suspicious activity around /api/settings endpoints are recommended. Finally, user education for administrators about phishing and social engineering can reduce the risk of user interaction-based exploitation.

Description

A vulnerability, which was classified as problematic, was found in atjiu pybbs up to 6.0.0. This affects an unknown part of the file /api/settings of the component Admin Panel. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. The identifier of the patch is 2fe4a51afbce0068c291bc1818bbc8f7f3b01a22. It is recommended to apply a patch to fix this issue.

References

Community reviews

Loading reviews…