Skip to main content
CVE-2025-8976VulnerabilityPublished

CVE-2025-8976: givanz Vvveb · Cross Site Scripting

Affects givanz VvvebSource CVE Database V5

0

Not known to be exploited · CVSS 5.1 Medium · fixed in 1.0.6 : update givanz Vvveb when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.0.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Affected software

ProductAffectedFixed in
givanz VvvebAffected
  • =1.0.0
  • =1.0.1
  • =1.0.2
  • =1.0.3
  • =1.0.4
  • =1.0.5
Fixed in–

AI-suggested

1. Immediate upgrade of givanz Vvveb to version 1.0.6 or later, which contains the patch for this XSS vulnerability. 2. Implement Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts and reduce the impact of potential XSS attacks. 3. Conduct thorough input validation and output encoding on all user-supplied data, especially in the affected module and parameters, to prevent injection of malicious scripts. 4. Limit access to the /vadmin123/index.php endpoint by IP whitelisting or VPN access to reduce exposure. 5. Educate users and administrators about the risks of clicking on suspicious links or interacting with untrusted content. 6. Monitor web server logs and application behavior for unusual requests or signs of attempted exploitation. 7. Employ web application firewalls (WAF) with rules tuned to detect and block XSS attack patterns targeting the vulnerable endpoint.

Description

A vulnerability has been found in givanz Vvveb up to 1.0.5. This vulnerability affects unknown code of the file /vadmin123/index.php?module=content/post&type=post of the component Endpoint. The manipulation leads to cross site scripting. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.0.6 is able to address this issue. It is recommended to upgrade the affected component.

References

Community reviews

Loading reviews…