Skip to main content
CVE-2025-9136VulnerabilityPublished

CVE-2025-9136: libretro RetroArch · Out-of-Bounds Read

Affects libretro RetroArchSource CVE Database V5

0

Not known to be exploited · CVSS 4.8 Medium.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
libretro RetroArchAffected
  • =1.18.0
  • =1.19.0
  • =1.20.0
Fixed in–

AI-suggested

European organizations should promptly upgrade all instances of RetroArch to version 1.21.0 or later to fully remediate the vulnerability. Given the local attack vector, organizations should also enforce strict access controls on systems running RetroArch, limiting user privileges and preventing untrusted users from executing or manipulating the software. Implementing application whitelisting and monitoring for unusual local activity related to RetroArch can help detect potential exploitation attempts. Additionally, organizations should audit shared or multi-user environments where RetroArch is installed to ensure that only authorized personnel have access. Regularly reviewing and updating software inventory and patch management processes to include RetroArch and similar applications will reduce exposure to such vulnerabilities. Finally, educating users about the risks of running untrusted files or scripts within RetroArch can further mitigate exploitation risks.

Description

A flaw has been found in libretro RetroArch 1.18.0/1.19.0/1.20.0. This affects the function filestream_vscanf of the file libretro-common/streams/file_stream.c. This manipulation causes out-of-bounds read. The attack needs to be launched locally. Upgrading to version 1.21.0 mitigates this issue. It is recommended to upgrade the affected component.

References

Community reviews

Loading reviews…