CVE-2025-9260: Fluent Forms (WordPress plugin) · Deserialization of Untrusted Data
Affects Fluent Forms (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 6.5 Medium · fixed in 6.1.2 : update Fluent Forms (WordPress plugin) when convenient.
Data as of 26 Oct 2026, 12:55 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.1.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Sep 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| techjewel Fluent Forms – Customizable Contact Forms, Survey, Quiz, & Conversational Form Builder | Affected
| Fixed in– |
AI-suggested
Organizations should immediately verify the version of Fluent Forms installed on their WordPress sites and upgrade to version 6.1.2 or later, which contains the complete and stable patch for this vulnerability. If upgrading is not immediately possible, restrict access to the WordPress admin and subscriber-level accounts through strong authentication mechanisms and monitor for unusual activity. Disable the PHP allow_url_include directive if it is enabled, as this setting significantly increases the risk of remote code execution. Implement web application firewalls (WAFs) with rules targeting PHP Object Injection patterns and monitor logs for suspicious deserialization attempts. Conduct regular security audits of WordPress plugins and configurations to detect outdated or vulnerable components. Educate administrators about the risks of granting unnecessary privileges to users and enforce the principle of least privilege. Finally, maintain backups and incident response plans to quickly recover from potential exploitation.
Description
The Fluent Forms – Customizable Contact Forms, Survey, Quiz, & Conversational Form Builder plugin for WordPress is vulnerable to PHP Object Injection in versions 5.1.16 to 6.1.1 via deserialization of untrusted input in the parseUserProperties function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject a PHP Object. The additional presence of a POP chain allows attackers to read arbitrary files. If allow_url_include is enabled on the server, remote code execution is possible. While the vendor patched this issue in version 6.1.0, the patch caused a fatal error in the vulnerable code, due to a missing class import, so we consider 6.1.2 to be the most complete and best patched version
References
- wordfence.com/threat-intel/vulnerabilities/id/938e5d6b-1ad6-4021-a148-1d1c9e8a0a83?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/fluentform/tags/6.0.2/app/Services/FormBuilder/EditorShortcodeParser.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/fluentform/tags/6.0.2/vendor/wpfluent/framework/src/WPFluent/View/View.php (opens in a new tab)