Skip to main content
VulnerabilityPublished

CVE-2025-9308: yarnpkg Yarn · ReDoS

Affects yarnpkg YarnSource CVE Database V5

0

Not known to be exploited · CVSS 4.8 Medium · end of life, no fix coming : replace or isolate yarnpkg Yarn; no fix will be released.

Data as of 26 Oct 2026, 09:16 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
None coming – the product is end of life
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

No fix will be released: yarnpkg Yarn is end of life. Replace it, or isolate it from untrusted networks until you can.

Affected software

ProductAffectedFixed in
yarnpkg YarnAffected
  • =1.22.0
  • =1.22.1
  • =1.22.2
  • =1.22.3
  • =1.22.4
  • =1.22.5
  • =1.22.6
  • =1.22.7
  • =1.22.8
  • =1.22.9
  • =1.22.10
  • =1.22.11
  • =1.22.12
  • =1.22.13
  • =1.22.14
  • =1.22.15
  • =1.22.16
  • =1.22.17
  • =1.22.18
  • =1.22.19
  • =1.22.20
  • =1.22.21
  • =1.22.22
Fixed in–

AI-suggested

European organizations should prioritize upgrading to supported Yarn versions beyond 1.22.22, as these versions are no longer maintained and thus vulnerable. If upgrading is not immediately feasible, organizations should restrict local access to developer and build systems running vulnerable Yarn versions, enforcing strict access controls and monitoring for suspicious activity. Implementing endpoint protection and behavior-based anomaly detection can help identify attempts to exploit inefficient regex processing. Additionally, organizations can review and limit the use of untrusted input in Yarn configuration or scripts that might trigger the vulnerable code path. Incorporating Yarn usage into software supply chain security policies and ensuring build environments are isolated and hardened will reduce risk. Finally, organizations should maintain up-to-date inventories of development tools and dependencies to quickly identify and remediate unsupported or vulnerable components.

Description

A vulnerability has been found in yarnpkg Yarn up to 1.22.22. This impacts the function setOptions of the file src/util/request-manager.js. Such manipulation leads to inefficient regular expression complexity. Local access is required to approach this attack. This vulnerability only affects products that are no longer supported by the maintainer.

References

Community reviews

Loading reviews…