CVE-2025-9390: vim · Buffer Overflow
Affects vimSource CVE Database V5
Public exploit available · CVSS 4.8 Medium · fixed in 9.1.1616 : patch vim as a priority.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.1.1616
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 24 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| vim | Affected
| Fixed in– |
AI-suggested
- Immediate upgrade to vim version 9.1.1616 or later, which contains the patch for this vulnerability.
- Implement strict local user access controls and enforce the principle of least privilege to minimize the number of users who can execute vim locally.
- Monitor and audit local user activities on critical systems to detect any unusual usage patterns of vim or attempts to exploit local vulnerabilities.
- Employ application whitelisting or endpoint protection solutions that can detect or block exploitation attempts targeting vim or related processes.
- For environments where upgrading is delayed, consider restricting access to the xxd component or disabling it if not required, as it is the affected part of vim.
- Educate system administrators and users about the risk of local exploits and the importance of applying security updates promptly.
- Integrate vulnerability scanning tools in the patch management process to identify systems running vulnerable vim versions.
Description
A security flaw has been discovered in vim up to 9.1.1615. Affected by this vulnerability is the function main of the file src/xxd/xxd.c of the component xxd. The manipulation results in buffer overflow. The attack requires a local approach. The exploit has been released to the public and may be exploited. Upgrading to version 9.1.1616 addresses this issue. The patch is identified as eeef7c77436a78cd27047b0f5fa6925d56de3cb0. It is recommended to upgrade the affected component.
References
- vuldb.com (opens in a new tab)
- vuldb.com (opens in a new tab)
- vuldb.com (opens in a new tab)
- github.com/vim/vim/issues/17944 (opens in a new tab)
- github.com/vim/vim/pull/17947 (opens in a new tab)
- drive.google.com/file/d/1JLnqrdcGsjUhbYzIEweXIGZyETjHlKtX/view?usp=sharing (opens in a new tab)
- github.com/vim/vim/commit/eeef7c77436a78cd27047b0f5fa6925d56de3cb0 (opens in a new tab)
- github.com/vim/vim/releases/tag/v9.1.1616 (opens in a new tab)