Skip to main content
CVE-2025-9543VulnerabilityPublished

CVE-2025-9543: FlexTable (WordPress plugin) · Cross-Site Scripting (XSS)

Affects FlexTable (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 3.5 Low : upgrade to 3.19.2 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
3.5Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.19.2
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade FlexTable (WordPress plugin) to 3.19.2.

Affected software

ProductAffectedFixed in
FlexTableAffected
  • <3.19.2
Fixed in
  • 3.19.2

AI-suggested

To mitigate CVE-2025-9543, European organizations should immediately update the FlexTable plugin to version 3.19.2 or later once available, as this version addresses the sanitization and escaping issues. If you cannot patch yet, restrict administrative access to trusted personnel only and monitor admin activities for suspicious behavior. Implement additional input validation and sanitization controls on data imported from external sources like Google Sheets, potentially using custom filters or security plugins that enforce strict content policies. Deploy Content Security Policies (CSP) to limit the execution of unauthorized scripts on WordPress sites. Regularly audit multisite WordPress configurations to ensure that security capabilities like unfiltered_html are properly enforced and complemented by other security layers. Conduct security awareness training for administrators to recognize and avoid risky behaviors that could lead to exploitation. Finally, maintain regular backups and incident response plans to quickly recover from any potential compromise resulting from this vulnerability.

Description

The FlexTable WordPress plugin before 3.19.2 does not sanitise and escape the imported links from Google Sheet cells, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

References

Community reviews

Loading reviews…