Skip to main content
CVE-2026-0560VulnerabilityPublished

CVE-2026-0560: parisneo/lollms · Server-Side Request Forgery (SSRF)

Affects parisneo/lollmsSource CVE Database V5

0

Not known to be exploited · public detection template (Nuclei) · CVSS 7.5 High : upgrade to 2.2.0 soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.0 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.7% chance of exploitation in 30 days – higher than 77% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.2.0
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Mar 2026

  2. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade parisneo/lollms to 2.2.0.

Affected software

ProductAffectedFixed in
parisneoparisneo/lollmsAffected
  • ≥ unspecified, < 2.2.0
Fixed in–
GitHubparisneo/lollmspkg:github/parisneo/lollmsOther threatsAffected
  • <2.2.0
Fixed in
  • 2.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should consider restricting access to the vulnerable endpoint or implementing network-level controls to limit outbound HTTP requests from the application server. Monitoring and filtering user input to the /api/files/export-content endpoint may reduce risk but is not a guaranteed mitigation.

Description

CVE-2026-0560 is a Server-Side Request Forgery (SSRF) vulnerability in parisneo/lollms versions prior to 2.2.0. It exists in the /api/files/export-content endpoint where the _download_image_to_temp() function does not properly validate user-supplied URLs. This allows attackers to make arbitrary HTTP requests to internal network services and cloud metadata endpoints, potentially leading to information disclosure and internal network reconnaissance. The vulnerability has a high severity with a CVSS score of 7.5. There is no confirmed patch or official fix available at this time.

References

Community reviews

Loading reviews…